Unable to obtain IP address for android device

Apr 4, 2013 at 2:15 PM

Host System Configuration

Windows 7 (ver 6.1 SP1)

Android Device

Jelly Bean 4.1.2

The virtual router can start successfully and shares my Lan Connection but when it comes to connecting my android device it does not work. The device can scan the SSID and connects but keeps on Obtaining IP address. After a while the Virtual router shows:
Host name could not be found.
IP address could not be found.

I tried looking into the configuration the virtual router is using and below is a transcript of the same:

Wireless LAN adapter Wireless Network Connection 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Virtual WiFi Miniport Adapter
Physical Address. . . . . . . . . : 00-27-10-4C-5E-AD
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::640d:ba16:7291:e366%23(Preferred)
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 687875856
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-F4-0D-01-00-26-9E-FD-64-63
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Any help is highly appreciated.

Apr 6, 2013 at 5:19 AM
Same problem here.
I tried installing the beta version (v0,8).
My android device is able to connect to the hotspot but no internet access. :(
Apr 7, 2013 at 12:08 PM
you have enable sharing your internet. So other device through WiFi can connect to your WiFi hotspot
Apr 8, 2013 at 7:30 AM
I have a similar problem with Nokia 701 (Symbian Belle) phone. In my case it just takes a bit more time to obtain an IP adrress, but it works normally afterwards. The only problem is, that VirtualRouter doesn't wait so long to retrieve device info, so I can see just this...
Host name could not be found. 
IP address could not be found.
It would be nice to have the ability to refresh these information manually.
Apr 8, 2013 at 2:39 PM
It's the same for me and I have no clue, what has happened.
The whole morning had come messages like the described above

Host name could not be found.
IP address could not be found.

No I get a connection with an IP from my DHCP where the LAN-Controller is connected. I'm pretty sure, that as the router was working, the SmartPhone got an IP from the "Microsoft Virtual MiniPort adress-space.

I'm running W7 Ultimate SP1.

Would be happy and thankful for a solution, because the functionallity is great - if it works!!!

Apr 23, 2013 at 4:14 PM
Hello Champs,
I got the solution:-!!!!!!

Click on properties of your data card (If you are using it) connection.
Click on 5th tab "sharing"
Check mark on all the options there.
And re-enable your virtual network via following command:-

netsh wlan stop hostednetwork
netsh wlan start hostednetwork

Bingo!! It will work now.

It happens because the dial up connection has already leased the IP to your system but the virrtual adapter does not dials any conenction so does not gets IP from ISP's DHCP.

Let me know,If you face any issues further."Happy to Help:-)
Apr 23, 2013 at 10:15 PM
this is not solution - it's workaround :) But thank you anyways ;)
May 13, 2013 at 10:24 AM
That's not the point.
Connection is there, but the Android-device (but also another notebook) doesn't get an IP-adress:
Android says: ... getting IP-adress and VirtRout shows: Hostname / IP-adress could not be found

Any working solution?
Jul 1, 2013 at 4:00 AM
I HAVE THE SOLUTION!! Just follow this simple steps...

My problem was that I recieved an ip adress but the connection ended in less than a minute...

To fix this ..
first disconnect from the network .. go to wifi settings .. from there navigate to advanced wifi settings .. check the "Use Static Ip" then come back and enter password and connect to the wifi again .. now while it tries to connect .. go to advanced again and remove the check box and come back and see you will be connected !!!!
Funny fix ! Worked for me many times !!!
Jul 5, 2013 at 8:58 PM
This problem is very common with smartphones, many devices can't connect with wpa2 key.. It happen with routers and another network devices...
The solucion is use WEP key, but this application don't have that option :(
Oct 15, 2013 at 8:24 AM
Anyone got the solution? I'm getting the above error in addition to this - http://imgur.com/xBZ4VoI.png
Dec 18, 2013 at 6:11 AM
The Solution is to use a fixed IP address for the Virtual WiFi Miniport as follows:

IP Address:
Subnet Mask:

If connecting is still a problem then assign a Static IP address on the Android device wireless connection (Advanced Settings) as follow:

IP Address: (2 to 255)

If both of the above are used the connection time is almost instantaneous.

Tested with Galaxy Tab 10 and Galaxy Note 3

Jan 3, 2014 at 10:26 AM
Create a hosted network
run CMD as administrator, &

netsh wlan set hostednetwork mode=allow
netsh wlan set hostednetwork ssid=SSID
netsh wlan set hostednetwork key=PASSWORD

netsh wlan start hostednetwork

if other device can't obtain ip, disable after some trys or poor connection from hosted network

1 open control Panel
2 windows Firewall
3 Allow an App or feature through Windows firewall
4 Change Settings
5 tick on all BranchCache and in public,Private, press ok

then start hosted network
Feb 3, 2014 at 6:08 PM
Hi guys,
Ive made a little program that you can run in a batch file, so you dont have to type out those commands everytime. Ive tested it with ipods streaming music via airplay and with android devices, everything works fine with what ive tested. All you have to do is copy the code below into a text file and then rename it to 'anyname'.bat and paste into a folder called WLAN-AP in your program files then make a short cut of the bat file and edit the shortcut so that it runs as administrator by default. You might have to make two other text files in the same folder as the bat file called AP-KEY and another called AP-SSID, just make sure the names of the text files are correct, you dont need to type anything into them. Heres the code:

@echo ***************************************
@echo * -------- Windows 7 WLAN AP -------- *
@echo ***************************************
@echo off
Set /p Choice=Please Enter Choice --- "1" AP-On, "2" AP-Off, "3" AP-Settings, "4" AP-Config:
If /i %Choice%==1 goto On
If /i %Choice%==2 goto Off
If /i %Choice%==3 goto Details
If /i %Choice%==4 goto Configure
If /i %Choice% LSS 1 goto CError
If /i %Choice% GTR 4 goto CError

netsh wlan start hostednetwork>>null
@echo ----- WLAN-AP Started -----
Goto Start

netsh wlan stop hostednetwork>>null
@echo ----- WLAN-AP Stopped -----
Goto Start

CD C:/Program Files/WLAN AP
Set /p SSID=<AP-SSID.txt
Set /p Key=<AP-KEY.txt
@Echo ***************************************
@Echo * --------- WLAN AP Settings ---------
@Echo * AP SSID: %SSID%
@Echo * AP KEY: %KEY%
@Echo ***************************************
Goto Start

CD C:\Windows\System32\
Set /p SSID=Please Enter AP-SSID:
Set /p KEY=Please Enter AP-KEY:
netsh wlan set hostednetwork mode=allow ssid=%SSID% key=%KEY%>>null
CD C:/Program Files/WLAN AP
Echo %SSID%>AP-SSID.txt
Echo %KEY%>AP-KEY.txt
@echo ----- WLAN-AP Configured -----
Goto Start

@echo ***************************************
@echo * -------------- Error -------------- *
@Echo * The Choice Selected Does Not Exist *
@echo ***************************************
Goto Start
Feb 3, 2014 at 6:11 PM
Its the first time ive written a bat file so if there are horrible techniques... well sorry.
Oh and you have to manually share the connection with internet to the wifi connection, but you only have to do this once
Feb 4, 2014 at 8:35 AM
hey guys...i 'mHotspot' overcomes that problem of 'method can't invoke subscribers'
Apr 11, 2014 at 4:04 PM
WHEN I TRIED TO CONNECT I GOT ERROR THAT "The group or resource is not in the correct state to perform the requested operation."
The group or resource is not in the correct state to perform the requested operation."__

Apr 11, 2014 at 6:20 PM
you must insert in CMD
netsh wlan set hostednetwork mode=allow ssid=NETWORK key=password keyUsage=persistent
then you must restart your computer
in CMD = netsh wlan start hostednetwork
May 24, 2014 at 3:16 PM
WHEN I TRIED TO CONNECT I GOT ERROR THAT "The group or resource is not in the correct state to perform the requested operation."
The group or resource is not in the correct state to perform the requested operation."__

You might have disabled the Virtual network manually.
Try enabling the same from the Device management > Network adapters
Jun 11, 2014 at 12:30 PM
Guyzz m also gettin the same prob by it is more complicated, m gettin connected my android phone bt ths ("Host name could not be found.
IP address could not be found.") is showin on my virtual router manager(VRM) nd the another prob. also cums is tht whenever my device gets connected luckily to VRM at tht time my device shows Limited "Connectivity"
Please VRM Developers i request you all to inform us some conform solution,
Your loyal
Jun 14, 2014 at 11:14 PM
The only solution I found was to assign a static ip address to each device connected to the network.
IP Address: 192.168.137.(2-255)

I think the problem is that the DHCP server of the virtual wifi miniport adapter doesn't automatically assign an ip address to each device.

Dell Inspiron N4030
Windows 8.1 Pro
Jun 14, 2014 at 11:24 PM
Edited Jun 14, 2014 at 11:27 PM
That is not a solution - it would ruin the whole point of Virtual DHCP Server and router :)

BTW: Try this one... http://www.virtualwifirouter.com/ - if it works for you, authors should merge their projects to make a single one with better functions ;)
Jun 27, 2014 at 1:24 AM
Edited Jun 27, 2014 at 1:24 AM
Hey all,

I found a SOLUTION too, I tried the fixed IP thing above but I still could not connect to internet with my android phone, so as also suggested above by 'creetesh', I had to do something with the firewall, but I wanted to do it specific for the phone or the network or the IP. I also have Symantec Endpoint Protection (windows firewall is managed by SEP).

The idea is basically to allow traffic access to your phone. To do that securely, I used the mac address of my phone. I could have used the static IP as to be allowed but that is not very unique..

So, I went to SEP->Network Threat Protection -> Options -> Configure Firewall Rules -> Add

and I added a rule which gave the summary as (it's nice, you set the options and the program summarizes it);
_Rule Summary:
Allow both incoming and outgoing traffic to/from: MAC address bla-bla-bla. This applies to traffic from the following protocols and ports: All IP protocol types. For these network adapters: Microsoft Virtual WiFi Miniport Adapter (

I am sure you can do this by using the windows firewall options too.

Hope it helps.

Feb 6, 2015 at 11:39 AM

just have a look here. Perhaps this helps in your situation, too.

Kind regards.