Virtual Router v1.0 not working - my solution

Mar 30, 2013 at 10:39 AM
I "upgraded" to verison 1.0 but just could not get it to work (error 0x80040201) even after applying the Microsoft HotFix and doing multiple uninstalls, re-installs and reboots. I finally uninstalled it and re-installed the v0.9 Beta and all was well again. It seems the version 1.0 just did not find the shared connection. I hope this helps someone? For info I am using Win 7 Home Premium.

These are the steps I followed:

Uninstall Version 1.0 if necessary and reboot
Delete the Virtual Router Folder in Program Files (x86)
Run setup for the v0.9 Beta
When setup is complete:
1) Open Network & Sharing Center
2) Click Change Adapter Settings
3) Rename new wireless connection to a short name without spaces (our old friend DOS?!)
4) Right click Wireless Network Connection
5) Select Properties / Sharing tab
6) Tick top box "Allow other users to connect through this computer's connection"
7) Select newly named network connection in the dropdown box below
8) Click OK
9) Reboot

Interestingly the new installation remembered my old SSID and password?!
Nov 20, 2013 at 10:34 AM
The virtual router worked for me until windows 7 automatically updated my wireless driver. Got only the error 0x80040201 afterwards.
Tried all solutions mentioned on other topics but those just made stuff worse for me.
I just started the device manager and looked up my wireless card and selected the 'restore driver' function to use the old driver instead of the newer one.
Worked for me.
Aug 4, 2014 at 5:11 PM
The TigerTrader's solution worked here.
I have noticed one should not check ICS manually (or the vrouter won't be able to start); the program will set it up by itself.