Does not work, try this.

Mar 15, 2011 at 2:50 AM

1. Open a command-prompt with administrator privileges.

Click on Start menu, All Programs, Accessories, right-click on Command Prompt, select “Run as administrator”). Type in:

netsh wlan set hostednetwork mode=allow ssid=Test key=password

3. Configure Internet Connection Sharing (ICS)

Open up the networking control panel. Select the interface that currently has Internet connection (like your Ethernet or normal wifi), enable “Sharing”, and then select the special “hosted” interface (sometimes called a Virtual Wifi Miniport)

4. Start it by typing in this command

netsh wlan start hostednetwork

Thats it, no program needed. All the work has already been done by Micosoft, this works on Server 2008 and Windows 7 and above (2008 R2 SP1 etc)

Mar 16, 2011 at 5:26 PM

So I used this way to set up a wifi access point for my Samsung galaxy spica. Worked well until i connected it. It finds the hotspot, could connect it BUT i have no internet on my phone. Yes, I shared my cable internet connection with the virtual wifi miniport. Could the problem be because I need to configure the virtual wifi miniport (set IP, gateway etc) or what?
Thanks in advance.

Mar 18, 2011 at 7:25 AM
Edited Mar 18, 2011 at 7:25 AM

Hi Archzz,

Yes it might be an issue with the gateway or ip address, when you configure the internet sharing feature it you should be done as follows.

1: Find your able internet connection, right click on it and goto properties.
2: Find the shared tab, then select allow sharing then pick the wifi mini port adapter.

If this is what you have done then you might have an issue with the tcp ip stack.

You can rebuild you tcp ip stack by doing the following.

1: Click on Start button.
2: Type Cmd in the Start Search text box.
3: Press Ctrl-Shift-Enter keyboard shortcut to run Command Prompt as Administrator. Allow elevation request.
4: Type netsh int ip reset in the Command Prompt shell, and then press the Enter key.
5: Restart the computer.

By default when you share a internet connection it will automatically make the wifi mini port a DHCP server, however some phones may have an issue with this so you could also try setting the ip address on the phone, however personaly I would keep the ip address blank and just set the gateway and the DNS server if you have that option (both should be the ip address of your router)

As a sub note when you set this up make sure you only have one wifi device available (i mean one physical device) if you have two wifi cards on your computer unplug one of them or disable it when you first setup the wifi mini port (the steps in my original post)

Apr 2, 2011 at 10:45 PM

doesnt work here as well

this is too sad cuz it worked yesterday - first install

now it says could not be started



this is so bad i wish there was an irc chan

Aug 24, 2013 at 4:41 PM
Hello uhax,
I am facing this error:
"The Hosted network could not be started
The group or resource is not in the correct state to perform the requested operation"
when I typed this into cmd with Admin privileges:
"netsh wlan start hostednetwork"
Apr 12, 2014 at 7:45 AM
i m too getting same error please help me if you have got any solution
Jan 9, 2015 at 11:30 PM

I successfully got connected using my tablet but it does not provide ip address automatically, any sugessions on how to get this working right?

Satta matka
Jan 14, 2015 at 6:38 AM