"Could not be started" Problem Solved despite/thanks to CONNECTIFY

Sep 28, 2010 at 8:09 AM
Edited Sep 28, 2010 at 8:16 AM

VIRTUAL ROUTER MANAGER - "Could not be started" Problem Solved despite/thanks to CONNECTIFY

(for me, but can't hurt if you try)

"Virtual Router Manager" DID WORK BEFORE untill I reinstalled my computer and reinstalled "Virtual Router Manager"!

(Got "could not start" and "service not running"  messages all the time).

Because of my clean  install (of Win 7 64 bit) I suspect I muddled around with the network adapter settings before installing "Virtual Router Manager"  the first time (before clean install). 

I tried every possible setting on every adapter to try to recreate the right settings ... Did not work ...


So I decided to retrace my steps:  (How I got it working):

Starting with no network settings changed at all from clean Win install:

1) Install CONNECTIFY, (even though I knew it did not work). Try to connect to Connectify Network from other device (a Win 7 Starter for me).  It connects or limited connects, but no INTERNET ACCESS.

2) Shut down Connectify (no uninstall  if that makes any difference), INSTALL VIRTUAL ROUTER MANAGER.

3) Try to connect to VirtualRouter Network from other device, CONNECTS with VirtualRouter Network but says NO INTERNET ACCESS.

4) Open network and sharing (on the virtual host), change VirtualRouter Network from WORK to HOME.

5) Other Device: disconnect from VirtualRouter Network and reconnect: INTERNET ACCESS !!!

I'm a network dummie so don't ask me WHY, but hey, I got it working!
(Well, after a few clean installs of Win 7, three days of swearing and about 50 cups of coffee.)

Who knows this works for you who have problems too.


Oct 2, 2010 at 8:59 AM

I too have the problem. Was workingjust fine for days; then on morning of 2 October 2010, stopped working. Any attempt to restart gets message that the application has stopped (I use French version so I'm not too sure on the exact English translation.) Uninstalled and reinstalled - same thing... I am not aware that any new software was installed during the interval...

Help! Would be good to get working... Other such packages do not work or at least not with my wireless broadband internet connection - Virtual router the only one so far that allows me to share this connection over my netbook wifi... WAS pretty cool...


Jan 31, 2011 at 11:04 PM
Edited Jan 31, 2011 at 11:12 PM

Important Additional Information

I tried the Connectify fix and managed to get it to work much more easily.

  1. Install "Connectify".
  2. Set up your access point in Connectify and test that it works.
  3. Stop "Connectify" (otherwise you'll get blue screen after running for a few minutes).
  4. Delete the registry entry that makes "Connectify" start automatically with Windows (I use CCleaner to do this).  Do not uninstall Connectify.
  5. Start VirtualRouter.
  6. You will see the same access point name that you just set up with Connectify.  It should be ready to go, just click "Start Virtual Router".

If It Stops Working

I find that VirtualRouter will randomly stop working properly.  You will get an error either "Could not start..." or "Service is not running..." messages.  When this happens, I do the following:

  1. Open "Network and Sharing Center"
  2. Click "Change Adapter Settings"
  3. Right-click on your actual wireless network adapter (not the Microsoft Virtual WiFi Miniport Adapter)
  4. Choose "Repair"
  5. It may present you several options to repair, just click "Skip" to everything.  Even though you are skipping these repair options, I think it still resets the adapter.
  6. Open a command prompt with administrator privileges
  7. Enter the following command
netsh wlan start hostednetwork

You should see the response:

The hosted network started.

VirtualRouter should now be running properly.  If not, you may need to stop and restart VirtualRouter.