5
Vote

Ip Address and host Name not found.. plzz help

description

hi...
in my clg der is proxy server and different lan settings (ipv 4 ) in each hstl..
i.e
IPv4 Address: 10.10.105.169
IPv4 Subnet Mask: 255.255.255.0
IPv4 Default Gateway: 10.10.105.254
and Proxy Settings : 10.10.11.1 port 8080.
when i share my lan internet through wi fi using using Virtual Router Manager V1.0
wireless lan connection 2
ipv4 address in properties of same is 192.168.2.1
subnet mask 255.255.255.0
default gateway: . . .

but network conection (wlan connection 2)details are
Connection-specific DNS Suffix:
Description: Microsoft Virtual WiFi Miniport Adapter
Physical Address: ‎C0-18-85-91-34-35
DHCP Enabled: No
Autoconfiguration IPv4 Address: 169.254.78.197
IPv4 Subnet Mask: 255.255.0.0
IPv4 Default Gateway:
IPv4 DNS Server:
IPv4 WINS Server:
NetBIOS over Tcpip Enabled: Yes
Link-local IPv6 Address: fe80::d177:155f:1431:4ec5%15
IPv6 Default Gateway:
IPv6 DNS Servers: fec0:0:0:ffff::1%1, fec0:0:0:ffff::2%1, fec0:0:0:ffff::3%1

when i seach mynetwork through my phone ..iin virtual router
IP Address Not Found
Host Nme Not Found (errors occour)

tell me that in my phone which IPv4 IP Add, IPv4 Subnet and default gateway i has to put..

comments

pjiang wrote Jun 13, 2013 at 10:26 PM

I got the same symptom here, VR shows both Hostname and IP could not be found when I tried to connect my phone in.

By debugging into the code, seems IPInfo::GetIPInfo() returns null. It looks up from "arp -a" command result for my phone's MAC address, but there is no record there, so the mapping fails.

Could the author help to clarify:
1) Why my phone can not get a dynamic IP to connect in?
2) Any other way can I add my phone into the arp list? I tried it by running "arp -s", but it was soon disappeared.

I am using the latest VR 1.0 version, code checked out today.

Thanks for the help!
  • Paul

KeshavMukund wrote Dec 28, 2013 at 2:19 PM

Hi,
I was facing this problem today. Following solution worked for me.
On starting the software , IP of the virtual adapter of my Windows 7 system ( Host machine ) was 192.168.231.1
Until the mobile device trying to connect to Win 7 system has DHCP , it couldn't connect to the VR 1.0 network, and showed error mentioned by pjiang "IP Address Not Found Host Nme Not Found".

Change the mobile device to use static IP of 192.168.231.X series e.g. '192.168.231.9'. Default gateway of the mobile device has to be '192.168.231.1' i.e IP of Windows system running VR software. On changing thus, the mobile device no longer gave any error and connected immediately.

On the mobile device that I was using , I could configure static IP by chosing the network -> Modify Network Properties -> Show advanced options. I still am finding solution for mobile devices which don't allow changing connection mode to Static