TTL problem

Apr 17, 2013 at 8:52 PM
Edited Apr 17, 2013 at 8:53 PM
Virtual Router 0.9 Beta @ Windows 7 was working perfectly.
My ISP is setting TTL to 1; so I can't share my network connection.
With Virtual Router 0.9 Beta @ Windows 7 it was possible to connect from Android device to a Notebook with Viirtual Router 0.9 Beta onboard.

In windows 8 and Virtual Router 1.0, I can connect, to the hotspot, but the TTL on the device is 0.

I think there was a some sort of TTL incrementation in Virtual Router 0.9 Beta, but there isn't one in Virtual Router 1.0. I can install Virtual Router 0.9 Beta and Windows 7, and use the Internet on my Android phone, but I would like to do this from Windows 8.

Can you solve TTL incrementation problem in Virtual Router 1.0 ??
Jan 9, 2014 at 7:43 PM
I have exactly the same problem, my ISP capped internet sharing by setting the TTL to 1, I can't ping but can ping the default gateway with a TTL=0.
I have tried several patches, like setting the default TTL for ICS in registry and ATTLFilter addon for Windows Packet Filter Kit, none of them worked under my version of Windows ( I am running Windows 8.1 Pro on 64bit).
I also tried installing Virtual Router 0.9 beta and it gives me a very abstract error that sounds like "virtual router could not start". On virtual router 1.0 and other programs (connectify or mhotspot) I can create and connect to the network with my Android phone, but have no internet access.
I also grabbed the source code and opened it in VS2010 but I have no idea in what class to set the corresponding TTL (I have some basic knowledge about programming).

If someone could implement this in Virtual Router or help me make my own version, or found another way and like to share it, I would be very grateful.