Can't download the installer

May 19, 2012 at 4:01 PM

I need this software very much, but unfortunately, I cannot download it somehow.

I click the big purple [DOWNLOAD] button on its page and its brings me to a download page, and its says [downloading...], and I should wait and that it should start in 3 seconds.

I tried it several times but it seems that I can't pop out anything.

Could anyone give me a hand on this? Or maybe an alternate download link, or whatsoever?'

 

Thanks, I appreciate your time reading this.

May 20, 2012 at 4:45 AM

Do you have an ad blocker running? I had the same problem as you, but when I disabled my ad blocker it worked. 

May 20, 2012 at 8:16 AM

Yeah, I have one. Apparently it was the reason why the file does not download. I got to download it after I download it, thanks a lot man.

My only problem now is that I can't get it to start. My wireless adapter is compatible, as I have seen it in the list. But I  tried everything, but I can't make it to run. Any thoughts on this?