How to build a patch or a more recent commit

May 4, 2012 at 1:14 PM
Edited May 4, 2012 at 4:41 PM

Sorry, I'm not a programmer....

I have some problem with the current downloadable version of Virtual Router (0.9 beta - build 41272) (i.e. my shared connection changes after a few seconds and I can't have the right one currently selected).

I see that this bug (and others) have been corrected in some of the available patches, and probably on the last commit 56821).

But how can I make a new installer/or executable out of these new commits or patches?

I've just tried installing Microsoft Visual C# 2010 Express and loading the last commit (first time I try to compile a code !! what file must I load as a complet project?). In the loading process I received several error message, however I managed to make an ".exe" of the VirtualRouterClient of the source code and launching it. I can see that my previoulsy reported problem (the automatic change of the shared connection after few seconds) has been solved.

But how can I build a full executable program form that latest commit (with all the exe and dll required and the installation program)?

Or maybe someone can point me to some noob guide... I'm not interested in developing applications and learning C#. I just would like to be able to build an executable for Virtual Router, that is, apparently, the only program that makes my wifi adapter (RTL8187) work as an Access Point...

Thanks for your help.

Luca

May 4, 2012 at 2:35 PM

Well, you managed to create the executable file and it works, making an installer is a different project (but it is included in the solution) however I'm not sure if it will compile under Express editions.

You should see VirtualRouterClient and VirtualRouterInstaller on the Solution explorer (again, I'm not sure all projects from this solution will work on Express editions), but you should be able to select VirtualRouterInstaller and compile it to get the msi created. 

Please download the 30day trial of Visual Studio 2010 from microsoft.com/vs , or if you are a student, subscribe to dreamspark.com and get a free license for VisualStudio 2010 (and some other microsoft tools).

May 4, 2012 at 8:59 PM

Thanks Kryztoval

 

I downloaded Visual Studio Professional 2010 Professional - trial (2GB !) I also had to download ImageBurn to make use of the ISO file I downloaded.

It took about 2 hours to have it ready for installation. Then I tried to install VS but I received an error during the installation process.

So I'm afraid I'll give up. It seems that's out of my depth...

I just hope there will be soon a new build available of Virtual Router (fixing the existing bugs).

Thanks anyway

May 4, 2012 at 9:33 PM

If you give me a couple of days I can build a new installer and post it later, I think the project owner is quite busy too.

May 5, 2012 at 11:32 AM
Edited May 5, 2012 at 1:02 PM

Kryztoval

Thanks Kryztoval, it would be much appreciated.

Anyway at last I managed to install VS10 Pro (trial version) (Web installation worked). So I followed your instructions: selected VirtualRouterInstaller and compiled it to get the msi created (for this I used the last source code 56821) 

Then I installed this new build 56821 (after uninstalling the official published 0.9 beta version).

The main window opens but there's a message in the notification bar saying "Can not manage Virtual Router. The Service is not running". All the option and settings in this main window are grayed out.

Yet I checked and the VirtualRouterService seems to be running.

So maybe I made some mistake in the compilation or there is some problem with this (unpublished) build.

 

Update

I made another trial compiling 41376 with Kryztoval patch (the one that solves the issue of the shared connection automatically changing after a few seconds). Installed it and run it.

It didn't work. It showed the same message as above ("Can not manage Virtual Router. The Service is not running")

This time I saved the installed files on another directory and uninstalled this patched and custom compiled version.

Then I re-installed the officially-published version (0.9 beta) and substituted the installed "VirtualRouterClient.exe" with the one coming from the patched 41376.

It worked!!!

Now I can change the shared connection and the one I choose stays put.

Unfortunately the first test of wifi connection with this taylored VirtualRouter lasted only for a short time.

At first I had a working connection, but, after a few minutes, I couldn't anymore access my ICS from my android phone and it seems that the VirtualRouterService stopped itself.

I'll make some more few experiments but I'm afraid I'll soon have to give up with Virtual Router.... unless someone can help me again with those new issues and some fresh advice...

 

 

Jun 1, 2012 at 5:20 AM
Edited Jun 1, 2012 at 5:23 AM

I find the bug you guys were referring to. It does have a easy workaround if you aren't the programming type.

DevCon Command Prompt Utility

1. devcon disable "device instance id for Microsoft Virtual Wifi Miniport Adapter" 

2. devcon enable "device instance id for Microsoft Virtual Wifi Miniport Adapter"  

Finding out the device instance id: http://wlanbook.com/enable-disable-wireless-card-command-line/

Non-Command Prompt (Slow way)

1. Access your network adapters. This can be done by accessing the Network and Sharing Center on the left side, choose Change adapter settings.

2. Right-Click Microsoft Virtual Wifi Miniport Adapter (commonly "Wireless Network Connection 2") and select disable.

3. Right-Click and enable Microsoft Virtual Wifi Miniport Adapter.

This can also be done through Device Manager.

If this doesn't seem to be a proper workaround, reset all your network adapters before enabling the Miniport again.

Usually, once resetting the Miniport, this bug goes away, but I have used the second part of this workaround a total of once.

I find that this bug commonly happens to me if my Miniport is connected and Virtual Router is not open. Boom. Bug dodged. Maybe restarting the Miniport Adapter at program Startup. I love this program, the workarounds are pretty simple, I'll contribute my installer soon.