Virtual Router Could Not Be Started

Mar 1, 2011 at 6:22 PM

I am running Windows 7 Ultimate version with Service Pack 1 and Virtual Router Manager v0.9 Beta.  When I click on "Start Virtual Router", I got this message "Virtual Router could Not Be Started".  Can anyone help?  Many thanks in advance!

Mar 4, 2011 at 6:39 AM

Me too.

Mar 7, 2011 at 4:36 PM
Edited Mar 7, 2011 at 4:36 PM

Same "could not be started" message in the VR manager on Win 7 Pro SP1 64 bit system.  I can see two VR manager processes running and one service started.  The Win 7 compatibility tool suggested using Win XP SP2 settings but that did not work.  Attempting to repair the installation using Windows uninstall produced an installation error message.

Mar 10, 2011 at 6:18 PM

same problem "could not be started"

Mar 17, 2011 at 5:58 AM

I was hitting the very same issue, running Windows 7 Enterprise x64, with VirtualRouter 0.9Beta. The weird thing is that it used to work fine, then from one day to the next stopped working displaying the symptoms described above. Well, I found a way to fix it (for me at least). I discovered in the Windows Event Log (Administrative Tools-> Event Viewer), from the [Custom Views->Administrative Events] log, that corresponding to the times I was trying to start VirtualRouter, I was getting errors about IPV6 stating "The ICS_IPV6 failed to configure IPv6 stack.", event ID 34001, the event details contained the event name "IP_ICS_IPV6_LOG_CONFIG_IPV6_STACK_FAILED".

Googled it, and found that to get rid of such errors, the best way was to disable IPv6 altogether (no idea which sneaky Microsoft update enabled it to start with, as I clearly do not use IPv6 at all). To do so I followed a Microsoft support article:

http://support.microsoft.com/kb/929852/en-us

I used 0xffffffff for the [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\DisabledComponents] registry entry to disable IPv6 altogether, restarted my machine, et voila. VirtualRouter is back up humming nicely.

Hope this helps :)

Jun 24, 2011 at 6:00 PM

Same problem - Win7 64-bit, message "Virtual Router could Not Be Started"

IPv6 trick does not for me. However, I found issue with an old WiFi driver version. Driver is now updated to the latest version and Virtual Router works fine now.

Problem is that some drivers do not support "hosted network" feature. You can test this with command line: netsh wlan show drivers

If displays something like Hosted network supported : No then you should try to update the driver and run the command again. Virtual Router requires this flag to be set to Yes.

Reference: https://www.astrill.com/blog/index.php/tag/virtual-wifi/

Jun 26, 2011 at 5:50 PM

can anyone from CODEPLEX answer us ?

Jun 29, 2011 at 1:59 AM

I had to had a Bluetooth USB Dongle device plugged in then it shared the wireless 

Jul 19, 2011 at 4:57 AM

>open network and sharing settings

>manage wireless networks

right click on your connected device and select properties.

check connect even if the network is not broadcasting its name(SSID)

also check enable WLAN connection settings

press ok.

now open virtual router and put a password ans start virtual router.

Jul 20, 2011 at 11:36 PM
Edited Jul 20, 2011 at 11:36 PM

I get the same message. None of the suggested changes make any difference!

Jul 24, 2011 at 5:02 PM

hi, after 4 install/uninstall cycles and updating my wifi driver from http://www.atheros.cz/  i have now got it working with win 7

i also tryed the following before reinstalling and updating and im not sure if it changed anything or not.

 

 

If getting problem in starting Virtual Router, I may recommend you to use first cmd lines for Creating Microsoft Virtual WiFi Miniport Adapter Windows 7 has an excellent in-built utility, Wireless Hosted Network (Virtual Wifi) technology, that makes your computer, a wireless access point and you can connect all your network devices by sharing a single internet connection thorough your computer or laptop. Here’s how to set it up.

1. Open command prompt with Administrator privileges. (You can do it by going to start menu/all programs/accessories, right clicking on command prompt and selecting “Run as administrator”).

2. Enter the following command: netsh wlan set hostednetwork mode=allow ssid=Test key=YOUR PASSWORD GOES HERE

Keep this window open as you will need it later (This will create a wireless access-point with SSID of “Test” Windows-7-Wifi-Setup)

3. Open the Networks and Sharing Center

4. Select your mode of connecting to the internet (ethernet, wi-fi, cable etc.)

5. Enable sharing and select special ‘hosted’ interface or Wireless Connection (i.e. Virtual Wifi miniport)

6. Start it with the following command:  netsh wlan start hostednetwork

Source: http://www.techylabs.com/setting-up-a-virtual-router-in-windows-7.html And you’re Done!

 

Tips: 1.Don't use any Wifi connections before starting Virtual Router may create Problem. 2.In Device Manage download Online, Latest Microsoft Virtual WiFi Miniport Adapter in case of problem. Then after few days try to connect through Virtual Router pppoe, you can. Just see this pic to share http://i54.tinypic.com/15moh77.jpg ; My wireless connection 4 is Microsoft Virtual WiFi Miniport Adapter. First you need to connect Internet and then start virtual router and then start. When You successfully share Internet with virtual router you will see this. http://i53.tinypic.com/300y0ck.jpg Network Connections Page: http://i56.tinypic.com/m93gbt.jpg Virtual Router Screen Shot: http://i54.tinypic.com/spzrtj.jpg Color Red: Confidential Color Black: This may confuse you because I already :))) Hope it Helps and will save time. :))

Oct 26, 2011 at 10:29 AM

Hi everybody.

After a long chaos I could finally reach the solution to the problem. When you face this problem try changing the name of your connection to a single word one eg. "router" or "virtual" only. Remember to keep the name of one digit only. and make sure your computer is already on a network.

Write to me on FB

Nov 12, 2011 at 4:40 PM

hi guys...

try do this...its working for me so far...

follow user_01 post which you need to type command line in the cmd with several addition...

1. Open command prompt with Administrator privileges. (You can do it by going to start menu/all programs/accessories, right clicking on command prompt and selecting “Run as administrator”).

2. Enter the following command: netsh wlan set hostednetwork mode=allow ssid=Test key=YOUR PASSWORD GOES HERE

Keep this window open as you will need it later (This will create a wireless access-point with SSID of “Test” Windows-7-Wifi-Setup)

3. Open the Networks and Sharing Center

4. Select your mode of connecting to the internet (ethernet, wi-fi, cable etc.) (this one i just go to my broadband properties and on the sharing tab i tick allow sharing connection and choose my broadband connection)

5. Enable sharing and select special ‘hosted’ interface or Wireless Connection (i.e. Virtual Wifi miniport)

6. Start it with the following command:  netsh wlan start hostednetwork

after that restart your pc...

then go to C:/program files/Virtual Router and click (VirtualRouterHostConsole.exe) with administrator privileges...

cmd will pop out and state STARTING SERVICES...

my wifi is not compatible so error screen that ask me to close or troubleshoot will pop out later...i just close it and start virtual router on start menu...you will notice that virtual router already connected...

each time i want to use virtual router i only click (VirtualRouterHostConsole.exe) and the error pop up always show up....

it is easy when i put it as shortcut on desktop...

i did this because im using usb broadband...

just want to share....

sorry for my bad english...

 

Nov 12, 2011 at 4:45 PM

one more thing if u try my method dont change ssid name on virtual router...

keep VirtualRouter as ssid name for my method to work....

Nov 25, 2011 at 6:33 PM

Got a fix guys. Simple and non-complicated.

1) Open the Network and Sharing Center.

2) Select Change Adapter Settings on the left tab.

3) Double click on the connection Microsoft Virtual WiFi Miniport A... to re-enable Virtual Router.

4) Enjoy using Virtual Router once more.

Jan 3, 2012 at 12:52 AM
Edited Jan 3, 2012 at 1:06 AM

I`m using Intel Wireless WiFi Link 4965AGN I try all the replys but dont work....

Please make a compatibility for my device.....

 

Note: When i use netsh wlan start hostednetwork

No posible start a hostednetwork  the group not be in the correct state to execute the requested operation.

Obs: when i execute  C:\Program Files (x86)\Virtual Router Console

ERROR: Virtual Router could not be started. Supported hardware may not have been found.

Starting services...

and the windows was closed. 

Jan 22, 2012 at 10:30 AM

Hy, i got the same error...

it's strange, because i used perfectly Virtual Router fora couple of week , and now, the message "virtual router can not be started" appears....

and i can't use it anymore.

I have changed nothing on my computer..only the normal windows update.....

can anyone help ??

all of your trik didn't works.....

maybe a fix can solve that point ?

 

thx

Feb 22, 2012 at 11:46 AM

May b its silly but i always forget to switch the wirless button on ROFL

(the button which activates the bluetooth/wlan) 

Apr 2, 2012 at 5:34 PM

After trying one thing after another with no success, I walked away for a few minutes with virtual router manager open and waiting to be started.  When I came back I tried it one last time and it worked.  Now, I open virtual router manager and wait several minutes before clicking start virtual router and it works.

I am using it so I can download books with my usb modem and then transfer them to my Kindle.

Apr 13, 2012 at 1:42 PM
Edited Apr 13, 2012 at 1:42 PM

Read the manual

Apr 20, 2012 at 12:18 PM

 

read my post maybe it will work for you guys

http://virtualrouter.codeplex.com/discussions/350271

Apr 20, 2012 at 12:19 PM

hope it will help

Jun 5, 2012 at 5:03 PM

In my case enabling windows firewall (I had disabled as I am using a third party firewall) did the job perfectly for me.

As to share internet connection its mandatory to have windows firewall enabled.

Jul 13, 2012 at 2:36 PM

The solution for me was to turn off Windows Firewall, then turn it back on again.

Control Panel, System and Security, Windows Firewall, Turn Windows Firewall on or off:

Toggle firewalls to off, ok, then repeat to turn them back on.

 

More details:

Fresh install, Windows 7 32-bit, sharing wifi over wifi, card supports hosted network.

I could run the GUI and set the options, but was only able to start it using netsh in the command line.

Sep 29, 2012 at 9:51 PM

hi this software does nt wrk at for me, i keep saying virtual router could nt be  started. pls can u send hw i can resolve the problem kindly send it to my email abubakar.dapo@yahoo.com

Nov 8, 2012 at 8:11 AM

I found that uninstalling any "Wifi Manager" software seemed to do the trick. E.g. the Broadcom Wifi manager that came with my Dell laptop.

Dec 6, 2012 at 11:23 AM

Christ, people. This must be the biggest pile of shit ever coded and presented as actual software. NONE OF THE TIPS presented works, or does a single bit of difference. NOT A SINGLE THING HELPS! This POS software just stops working, and the nothing can get it working again, except maybe a hd format and reinstall.

And the people making this - you don't offer ONE F**KING PIECE of help AT ALL! Wtf?!?!?!

Dec 6, 2012 at 11:39 AM

I cannot even get to the point where I can TRY to start it. When I start the virtual router manager, everthing is greyed out and the message "Cannot manage virtual router. The service is not running." shows. So trying again, clicking OK again or anything like that is not an option, since everything is F**KING disabled.

Jan 17, 2013 at 4:24 AM

Ok.. I installed and it worked right away for about a day and a half and then I wound up here as well.  Yes it is annoying that it quits working but all I had to do to get going was

1. control panel - network and sharing center - (left panel) change adapter settings. 

 

2. find connection that says Microsoft Virtual WiFi Miniport A..  -right click on it and press disable. (Take note of connection number) - close window

 

3. double click on your current connection you use to go online. - click sharing tab - make sure share connection is enabled. - if it already is uncheck and recheck box. - close window.

 

4. right click on Microsoft Virtual WiFi Miniport A.. once more and click enable. - close all windows

 

5. open virtual network. - choose the Microsoft Virtual WiFi Miniport A.. as the network to share. should be the highest number network for most people.(connection number for you can be noted in step 2. if you forgot or didnt read all of this before doing these steps.....)

 

6. click connect and see if you have access to the internet once more.  I can find more solutions to this problem as well if anyone needs. just let me know.

 

7. When it happens again now you know. - hope that helps - www.thelinuxmotion.org

 


Feb 17, 2013 at 10:21 AM
Edited Feb 17, 2013 at 10:23 AM
it will 100% work in windows 7 ultimate...just make it a shared connection

control panel>view network status and tasks...under 'access type' you will see 'connections' with a sign of usb cable.click on your connection(e.g. Tata Indicom) and then properties>sharing>allow other network users to connect through this computer internet connection...and tick 'allow other network users to control or disable the shared internet connection'....you may make 'home networking connection' wireless network connection....click ok.

enjoy!
Mar 25, 2013 at 12:58 AM
i am getting the following error when i click on "start virtual router" -->"the dependency service does not exist or has been marked for deletion.(exception from HRESULT: 0x80070433)"

please help!
Mar 25, 2013 at 10:55 AM
maverick131 wrote:
i am getting the following error when i click on "start virtual router" -->"the dependency service does not exist or has been marked for deletion.(exception from HRESULT: 0x80070433)"
Just a tip: check if you have "Client for Microsoft Network" enabled in network properties.

Image
Mar 25, 2013 at 11:54 AM
yes i have "Client for Microsoft Networks" enabled.

still the same message.
Apr 20, 2013 at 4:51 PM
I have found way to solve this problem. Read here --> http://learnh0w.blogspot.com/2013/04/virtual-router-problems.html#more . 100% work for window 7. Other window i don't sure. Just try it.
Apr 30, 2013 at 12:53 AM
HELLO GUYS.....

I FINALLY FOUND IT MYSELF.......TRY THIS..
(make sure you have opened virtual router once before the procedure)

1) Go to the task manager

2) Make sure there is Virtual Router in the name column (which shows stopped in the status column )

3) Click on the __service...__button in the bottom right of the task manager . This will display the service window.

4) In the service list that appear search for VirtualRouterService. Righy click this and start the service...
ENJOY...
WORKS SURE
May 28, 2013 at 8:05 PM
Just encountered the same problem:

win 7
laptop acer aspire 5315

problem: router inactive
soln: downloaded the latest wifi driver from acer website and router manager now works.
Jul 16, 2013 at 12:17 PM
Hi

I solved.

I have changed as follows.
  1. "Allow other network users to ...." -> Checked.
  2. Start Virtual Router
Image

Thanks.
Jul 25, 2013 at 6:34 PM
I need a fix for Windows 8 pleaseee this is the only way for me to play my games online D:
Jul 25, 2013 at 6:37 PM
I HATE YOU! THAT TURNS OFF MY LAN!
Jul 25, 2013 at 6:38 PM
Nope. There's not VirtualRouter service.
Aug 1, 2013 at 3:42 AM
I was able to get it started by going to my device manager and starting my "Microsoft Network Hosted Virtual Adapter". Don't know why it was turned off.

This was after a number of uninstall/restart attempts.

After that, I was good to go

btw - this was on windows 8. no idea about win 7
Oct 14, 2013 at 11:28 PM
Well, I was having the same problem. At first, my wifi (inbuilt device in laptop) started getting off as soon as I used to put my laptop on LAN (wired). solved that problem by using cmd and some following commands may help if you got the same case.

netsh wlan set hostednetwork mode=allow

just restart your PC after using this command in cmd. ( make sure you run CMD with administrative privileges)

After that, I started getting the message something like

"cannot manage virtual router the service is not running"

and started reading all you guys are discussing about in this thread...

It say's service isn't running . So,
I just started the ( virtual router service ) by going to RUN > services.msc > Virtual Router Service ( just right click on it and click Start )
this software's working awesome for me :)

Windows 7 platform, dell laptop i5 2520M, Intel Centrino Advance N-6205 (Wifi adapter ) , Microsoft virtual Wifi Mini Adapter
Thanks
Dec 25, 2013 at 4:37 AM
keshasuxx wrote:
it will 100% work in windows 7 ultimate...just make it a shared connection

control panel>view network status and tasks...under 'access type' you will see 'connections' with a sign of usb cable.click on your connection(e.g. Tata Indicom) and then properties>sharing>allow other network users to connect through this computer internet connection...and tick 'allow other network users to control or disable the shared internet connection'....you may make 'home networking connection' wireless network connection....click ok.

enjoy!
Thanks Man... It worked
Jan 6 at 12:39 PM
Register just to share how i make it work.
Win 7/64 enable win firewall or any other firewall (important), before u click start hotspot disable and enable adapter (wirelles network conection).
Cheers.