I can't choose to share internet connection...

Apr 18, 2010 at 2:07 PM

I can see it into the dropdown list(my PPPOE connection), but after i choose it the app resets to the first item of the list (the LAN),like it is not an allowed choice(but, in this case why does the app show it in the list? :-) ) and, obviously when the virtual router starts I have only a connection to my LAN without internet access...Any suggestions?

myHardware: Notebook Packard Bell TJ65, windows7 64bit

client I want to connect: android  htc tattoo

Thanks in advance for all your replies...

Bye,

Esses.

 

P.S.: I use only with this connection so if there is an way to force the use of this connection, let me know if there are some settings to do this by coding and I'll try to do them...

May 5, 2010 at 5:13 PM

same problem ... (((

May 11, 2010 at 3:45 AM

Not sure if this will help but after playing with this app and its competitor (Connectify) i have noticed that both apps are extremely buggy (Virtual Router is littered with bugs).  Anyway, after alot of frustration i ended up making my own shell commands to do pretty muhch the same thing that this app does but now with no crashing and no fuss so i am happy.

But for your problem just to let you know for ICS to work you need to make sure the "Windows Firewall" service is running...it doesnt necessarily mean you have the firewall active (i hate the damn thing and it is disabled on my machine) but for ICS to work this service needs to still be running in the background...so for me i disabled the Firewall and then went into services.msc and made sure it was set to "Automatic" and "Started"....Without this service ICS will refuse to let Virtual Wifi to function properly.

 

Btw, Connectify seems to be a better product than this but the problem with it is that it hardcodes 192.168.2.1 regardless of any attempts by you to  change this default ICS address via the registry.  That pretty much makes Connectify useless for anyone who has a gateway on 192.168.2.1....at least Virtual Router doesnt have that problem...Virtual Router's problem is that it is too unstable.....

 

So like i said, for me i ended up just making my own solution since both products are just good ideas with poor executions.

Jan 5, 2012 at 5:05 AM

brand404,

Would you be kind enough to share your solution please? :)

Thanks!

Jul 23, 2012 at 3:48 PM

As with the OP, original post, I cannot choose the shared connection. One connection is my wired, Local Area Connection, and the other is my wireless, Wireless Network Connection. It forces me to us the wireless connection as the shared connection.

I can disconnect the wireless, and then the wired connection becomes my shared connection. And Virtual Router works with both. Unfortunately, when I disconnect the Wireless Network Connection, I lose network connectivity with other devices and computers on our local network.

Wouldn't it be preferable to have the internet routed through the faster, wired connection?

Is there a network or firewall setting to work around this issue?

Or is this really not an issue?